PAT-basic-1031 查验身份证

发布时间 2023-04-21 00:11:02作者: 正明小佐

一、题目


一个合法的身份证号码由17位地区、日期编号和顺序编号加1位校验码组成。校验码的计算规则如下:

首先对前17位数字加权求和,权重分配为:{7,9,10,5,8,4,2,1,6,3,7,9,10,5,8,4,2};然后将计算的和对11取模得到值Z;最后按照以下关系对应Z值与校验码M的值:

Z:0 1 2 3 4 5 6 7 8 9 10
M:1 0 X 9 8 7 6 5 4 3 2

现在给定一些身份证号码,请你验证校验码的有效性,并输出有问题的号码。

输入格式:

输入第一行给出正整数)是输入的身份证号码的个数。随后行,每行给出1个18位身份证号码。

输出格式:

按照输入的顺序每行输出1个有问题的身份证号码。这里并不检验前17位是否合理,只检查前17位是否全为数字且最后1位校验码计算准确。如果所有号码都正常,则输出All passed

输入样例1:

4
320124198808240056
12010X198901011234
110108196711301866
37070419881216001X

输出样例1:

12010X198901011234
110108196711301866
37070419881216001X

输入样例2:

2
320124198808240056
110108196711301862

输出样例2:

All passed

二、解析


按部就班验证即可。

三、代码


java:

package shuati;

import java.util.Scanner;

public class PAT_BASIC_1031 {
    private static int weight[] = {7,9,10,5,8,4,2,1,6,3,7,9,10,5,8,4,2};
    private static char code[] = {'1' ,'0', 'X', '9', '8', '7', '6', '5', '4', '3', '2'};
    private static Scanner input = new Scanner(System.in);
    public static void main(String[] args) {
        int flag = 1;
        int n = input.nextInt();
        for(int i=0; i<n; i++){
            String str = input.next();
//            System.out.println(str);
            int sum = 0;
            int j;
            for(j=0; j<str.length()-1; j++){
                char ch = str.charAt(j);
                sum += (ch - '0') * weight[j];
            }
            int actCode = sum % 11;
            if(code[actCode] != (int)str.charAt(j)){
                flag = 0;
                System.out.println(str);
            }
        }
        if(flag == 1)
            System.out.println("All passed");
    }
}

 

c++:

//
// Created by dongdong on 2023/4/13.
//
#include "iostream"
static int weight[] = {7,9,10,5,8,4,2,1,6,3,7,9,10,5,8,4,2};
static char code[] = {'1' ,'0', 'X', '9', '8', '7', '6', '5', '4', '3', '2'};
int main(){
    int n, flag = 1;
    scanf("%d", &n);
    std::string s;
    scanf("%s", s.c_str());
    printf("%s", s.c_str());
    char* ch = new char[18];
    for(int i=0; i<n; i++){
        scanf("%s", ch);
        int sum = 0;
        int j;
        for(j=0; j<17; j++){
            sum += (ch[j] - '0') * weight[j];
        }
        int actCode = sum%11;
        if(code[actCode] != (int)ch[j]){
            flag = 0;
            printf("%s\n", ch);
        }
    }
    if(flag == 1)
        printf("All passed");
    return 0;
}