PAT_A1029 Median

发布时间 2023-10-24 11:05:24作者: 永无荒城

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤2×105) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output Specification:

For each test case you should output the median of the two given sequences in a line.

Sample Input:

4 11 12 13 14
5 9 10 15 16 17

Sample Output:

13
#include<bits/stdc++.h>
using namespace std;
const int N = 200000+5, inf = (1<<31)-1;
int n, m, a[N], b[N];

int main(){
	scanf("%d", &n);
	for(int i = 0; i < n; i++) scanf("%d", &a[i]);
	a[n] = inf; // 末尾添加哨兵节点 
	scanf("%d", &m);
	for(int i = 0; i < m; i++) scanf("%d", &b[i]);
	b[m] = inf;
	int mi = (n+m-1)/2, i = 0, j = 0;
	while(i+j < mi)	
		a[i] < b[j] ? i++ : j++;
	printf("%d", a[i] < b[j] ? a[i] : b[j]); 
	return 0;
}

总结
1、 #two_pointers
令两个序列的最后都添加一个很大的数($2^{31}-1$)作为哨兵节点,可以简化代码,解决数组问题。
2、使用cin、cout会超时。