PHONELST - Phone List

发布时间 2023-06-12 19:44:09作者: Joker__King

PHONELST - Phone List

题面翻译

【题目来源】

Poj3630

【问题描述】

给定n个长度不超过10的数字串,问其中是否存在两个数字串S,T,使得S是T的前缀。有多组数据,数据组数不超过40。n<=10000。

【输入格式】

第一行,一个整数T,表示数据组数。
对于每组数据,第一行一个数n,接下去n行,输入n个数字串。

【输出格式】

对于每组数据,若存在两个数字串S,T,使得S是T的前缀,则输出“NO”,否则输出“YES”。

【数据规模】

n<=10000

题目描述

Phone List

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:

  • Emergency 911
  • Alice 97 625 999
  • Bob 91 12 54 26

In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.

输入格式

The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.

输出格式

For each test case, output “YES” if the list is consistent, or “NO” otherwise.

样例 #1

样例输入 #1

2
3
911
97625999
91125426
5
113
12340
123440
12345
98346

样例输出 #1

NO
YES

#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<cstring>

using namespace std;

int t, n;

struct String {
	char a[11];
	int len;
};

struct Trie {
	int trie[57000][10], tot = 1;
	int end[57000];
	inline void Clear() {
		memset(trie, 0, sizeof(trie));
		memset(end, false, sizeof(end));
	}
	inline bool Insert(char *str) {
		int len = strlen(str), p = 1;
		for (int i = 0; i < len; ++ i) {
			int ch = str[i] - '0';
			if (trie[p][ch] == 0) {
				trie[p][ch] = ++ tot;
			}
			if (end[p] == true) return true;
			//因为是从小到大排序
			//所以小的字符串已经先前被处理完
			//可以在插入得时候进行判断,是否存在先前在路径结尾 
			p = trie[p][ch];
		}
		if (end[p] == true) return true;
		end[p] = true;
		return false;
	}
}tree;

inline bool cmp(const String &a, const String &b) {
	return a.len < b.len;
}

int main() {
	scanf("%d", &t);
	while (t --) {
		scanf("%d", &n);
		String s[10004];
		tree.Clear();
		for (int i = 1; i <= n; ++ i) {
			scanf("%s", s[i].a + 1);
			s[i].len = strlen(s[i].a + 1);
		}
		//从小往大排序 
		stable_sort(s + 1, s + 1 + n, cmp);
		bool flag = false;
		for (int i = 1; i <= n; ++ i) {
			flag = tree.Insert(s[i].a + 1);
			if (flag == true) {
				break;
			}
		}
		if (flag == true) printf("NO\n");
		else printf("YES\n");
	}
	return 0;
}