1002 A+B for Polynomials C++

发布时间 2023-07-10 21:46:30作者: 正明小佐

This time, you are supposed to find  where  and  are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

     ...  

where  is the number of nonzero terms in the polynomial,  and  () are the exponents and coefficients, respectively. It is given that .

Output Specification:

For each test case you should output the sum of  and  in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

题意:

题目意思是计算两个多项式的加法。

分析:

水题。用水桶法,用数组下标表示指数,数组值表示系数,逆序输出,值为0则不输出。

代码:

//
// Created by yaodong on 2023/7/5.
//
#include "iostream"
#include "cstring"
int main() {
    double num[1001];
    memset(num, 0, sizeof(num));
    int k, exp;
    double coe;
    std::cin >> k;
    for (int i = 0; i < k; ++i) {
        std::cin >> exp >> coe;
        num[exp] += coe;
    }
    std::cin >> k;
    for (int i = 0; i < k; ++i) {
        std::cin >> exp >> coe;
        num[exp] += coe;
    }
    int len = 0;
    for (int i = 0; i < 1001; ++i) {
        if(num[i] != 0)
            len++;
    }
    std::cout << len;
    for (int i = 1000; i >= 0; --i) {
        if(num[i] != 0)
            printf(" %d %.1f", i, num[i]);
    }
}