1066 Root of AVL Tree

发布时间 2023-05-25 09:19:16作者: Yohoc

题目:

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

F1.jpg F2.jpg

 

Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (20) which is the total number of keys to be inserted. Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the root of the resulting AVL tree in one line.

Sample Input 1:

5
88 70 61 96 120
 

Sample Output 1:

70
 

Sample Input 2:

7
88 70 61 96 120 90 65
 

Sample Output 2:

88

 

 

代码:

#include<stdio.h>
#include<iostream>
#include<algorithm>
using namespace std;
int n;
struct Node{
    Node* lchild, *rchild;  
    int v;
};
void L(Node* &root){
    Node* temp = root -> rchild;
    root -> rchild = temp -> lchild;
    temp -> lchild = root;
    root = temp;
}
void R(Node* &root){
    Node* temp = root -> lchild;
    root -> lchild = temp -> rchild;
    temp -> rchild = root;
    root = temp;
}
int getHeight(Node* root){
    if(root == NULL) return 0;
    return max(getHeight(root -> lchild), getHeight(root -> rchild)) + 1;
}
void insert(Node* &root, int v){
    if(root == NULL){
        root = new Node();
        root -> v = v;
        root -> lchild = NULL;
        root -> rchild = NULL;
        return;
    }
    if(root -> v > v){
        insert(root -> lchild, v);
        if(getHeight(root -> lchild) - getHeight(root -> rchild) == 2){
            if(v < root -> lchild -> v){
                R(root);
            }else{
                L(root -> lchild);
                R(root);
            }
        }
    }else{
        insert(root -> rchild, v);
        if(getHeight(root -> rchild) - getHeight(root -> lchild) == 2){
            if(v > root -> rchild -> v){
                L(root);
            }else{
                R(root -> rchild);
                L(root);
            }
        }
    }
}
int main(){
    scanf("%d", &n);
    Node *root = NULL;
    for(int i = 0; i < n; i++){
        int data;
        scanf("%d", &data);
        insert(root, data);
    }
    printf("%d", root->v);
    return 0;
}