1086 Tree Traversals Again

发布时间 2023-05-20 11:10:36作者: Yohoc

题目:

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


Figure 1 

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop
 

Sample Output:

3 4 2 6 5 1

 

题目大意: 用栈的形式给出一棵二叉树的建立的顺序,求这棵二叉树的后序遍历

 

思路:根据给出的建立二叉树的栈操作,可以知道二叉树的前序遍历和中序遍历,从而就能够推导出二叉树的后序遍历。

如何得到前序遍历序列?每次Push操作的操作树按顺序插入数组,最终得到的数组就是前序遍历数组。

如何得到中序遍历序列?每次Pop操作从栈顶弹出的序号按顺序插入数组,最终得到的数组就是中序遍历数组。

 

由前序和中序遍历推到后序遍历的代码如下:(递归)

void postorder(int root, int start, int end) { // root是在前序遍历中根的下标 start 和 end是中序遍历的区间
    if (start > end) return;
    int i = start;
    while (i < end && inOrder[i] != preOrder[root]) i++;
    postorder(root + 1, start, i - 1); // left
    postorder(root + 1 + i - start, i + 1, end); //right
    postOrder[post++] = preOrder[root];
}

 

 

代码:

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<stack>
using namespace std;
int preOrder[35], inOrder[35], postOrder[35];

int pre = 0, in = 0, post = 0;
stack<int> s;
int n;
void postorder(int root, int start, int end) {
    if (start > end) return;
    int i = start;
    while (i < end && inOrder[i] != preOrder[root]) i++;
    postorder(root + 1, start, i - 1);
    postorder(root + 1 + i - start, i + 1, end);
    postOrder[post++] = preOrder[root];
}
int main(){
    scanf("%d", &n);
    for(int i = 0; i < 2 * n; i++){
        string op; 
        int x;
        cin>>op;
        if(op == "Push"){
            cin>>x;
            s.push(x);
            preOrder[pre++] = x;
        }else if (op == "Pop"){
            inOrder[in++] = s.top();
            s.pop();
        }
    }
    postorder(0, 0, n - 1);
    for(int i = 0; i < post; i++){
        if(i != 0){
            cout<<" ";
        }
        cout<<postOrder[i];
    }
    return 0;
}