hdu:Machine Schedule(二分图匹配)

发布时间 2023-08-28 22:56:06作者: ruoye123456

Problem Description
As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem.

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, …, mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, … , mode_m-1. At the beginning they are both work at mode_0.

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y.

Obviously, to accomplish all the jobs, we need to change the machine’s working mode from time to time, but unfortunately, the machine’s working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines.

Input
The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y.

The input will be terminated by a line containing a single zero.

Output
The output should be one integer per line, which means the minimal times of restarting machine.

Sample input
5 5 10
0 1 1
1 1 2
2 1 3
3 1 4
4 2 1
5 2 2
6 2 3
7 2 4
8 3 3
9 4 3
0

Sample output
3

二分图

最小顶点覆盖=最大匹配数

点击查看代码
#include<bits/stdc++.h>
using namespace std;
const int N=510;
int n,m;
int linker[N];
bool g[N][N],vis[N];
bool dfs(int x)
{
	for(int i=1;i<=m;++i)
	{
		if(!g[x][i]||vis[i]) continue;
		vis[i]=true;
		if(!linker[i]||dfs(linker[i])) 
		{
			linker[i]=x;
			return true;
		}
	}
	return false;
}

int main()
{
	ios::sync_with_stdio(false);
	cin.tie(0);
	int k;
	while(cin>>n>>m>k,n)
	{
		memset(g,0,sizeof g);
		memset(linker,0,sizeof linker);
		for(int i=0;i<k;++i)
		{
			int o,a,b;
			cin>>o>>a>>b;
			if(a&&b) g[a][b]=1;
		}
		int res=0;
		for(int i=1;i<=n;++i)
		{
			memset(vis,0,sizeof vis);
			if(dfs(i)) res++;
		}
		cout<<res<<'\n';
	}
}