1043 Is It a Binary Search Tree (附测试点7分析)

发布时间 2023-05-22 11:23:12作者: Yohoc

题目:

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line YES if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NO if not. Then if the answer is YES, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

7
8 6 5 7 10 8 11
 

Sample Output 1:

YES
5 7 6 8 11 10 8
 

Sample Input 2:

7
8 10 11 8 6 7 5
 

Sample Output 2:

YES
11 8 10 7 5 6 8
 

Sample Input 3:

7
8 6 8 5 10 9 11
 

Sample Output 3:

NO

 

测试点7分析:

测试点7的输出的NO,即给出的序列不是二叉树或其镜像的前序遍历序列。

本人开始的代码中,没有注意到,镜像二叉树中对于所有的结点,其左子树都要大于等于它, 右子树小于它,否则就不能称为镜像。(仅供参考)

 

 

代码:

#include<stdio.h>
#include<iostream>
using namespace std;
int n;
int preOrder[1005], postOrder[1005];
bool flag = true, s = false, isMirror = false;
void isBST(int l, int r){
    if(l > r){
        return;
    }
    int i, j;
    if(isMirror){
        for(i = l + 1; preOrder[i] >= preOrder[l] && i <= r; i++);
        for(j = r; preOrder[j] < preOrder[l] && j > l; j--);
        if(j + 1 != i){
            flag = false;
            return;
        }
    }
    if(!isMirror){
        for(i = l + 1; preOrder[i] < preOrder[l] && i <= r; i++);
        for(j = r; preOrder[j] >= preOrder[l] && j > l; j--);
        if(j + 1 != i){
            flag = false;
            return;
        }
    }
    isBST(l + 1, j);
    isBST(i, r);
}
void post(int l, int r){
    if(l > r) return;
    int i;
    if(isMirror){
        for(i = l + 1; preOrder[i] >= preOrder[l] && i <= r; i++);
    }
    if(!isMirror){
        for(i = l + 1; preOrder[i] < preOrder[l] && i <= r; i++);
    }
    post(l + 1, i - 1);
    post(i, r);
    if(s){
        printf(" ");
    }else{
        s = true;  
    }
    printf("%d", preOrder[l]);
}
int main(){
    scanf("%d", &n);
    for(int i = 0; i < n; i++){
        scanf("%d", &preOrder[i]);
    }
    if(preOrder[0] < preOrder[1]){
        isMirror = true;
    }
    isBST(0, n - 1);
    if(flag){
        printf("YES\n");
        post(0, n - 1);
    }else{
        printf("NO\n");
        return 0;
    }
}