1064 Complete Binary Search Tree

发布时间 2023-05-22 09:52:25作者: Yohoc

题目:

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key. 
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key. 
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0
 

Sample Output:

6 3 8 1 5 7 9 0 2 4

 

思路:

1、BST二叉搜索树的中序遍历数组一定是单调递增的,因此我们将结点从小到大排序即可得到二叉搜索树的中序遍历数组

2、已知中序/前序/后序遍历,直接求层序遍历(前提是完全二叉树)

int inOrder[1005], levelOrder[1005]; int k = 1;
void level(int root){
    if(root>n)return;
    level(root * 2);
    levelOrder[root] = inOrder[k++];
    level(root * 2 + 1);
}

 

代码:

#include<stdio.h>
#include<iostream>
#include<algorithm>
using namespace std;
int n, k = 1;
int inOrder[1005], levelOrder[1005];
void level(int root){
    if(root>n)return;
    level(root * 2);
    levelOrder[root] = inOrder[k++];
    level(root * 2 + 1);
}

int main(){
    scanf("%d", &n);
    for(int i = 1; i <= n; i++){
        scanf("%d", &inOrder[i]);
    }
    sort(inOrder + 1, inOrder + n + 1);
    level(1);
    for(int i = 1; i <= n; i++){
         if(i != 1){
              printf(" ");
         }
         printf("%d", levelOrder[i]);
    }
    return 0;
}