PAT-甲级-1005 Spell It Right C++

发布时间 2023-07-11 15:52:02作者: 正明小佐

Given a non-negative integer , your task is to compute the sum of all the digits of , and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an  ().

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five

题意:

题目意思是计算c=a+b,但是要按照英文输出c,50则输出five zero。

分析:

水题。

代码:

//
// Created by yaodong on 2023/7/11.
//
#include "iostream"

int main() {
    std::string n;
    std::cin >> n;
    int len = n.length();
    int sum = 0;
    for (int i = 0; i < len; ++i) {
        sum += n[i] - '0';
    }
    std::string number[] = {"zero", "one", "two", "three", "four",
                            "five", "six", "seven", "eight", "nine"};
    std::string sumString = std::to_string(sum);
    for (int i = 0; i < sumString.length(); ++i) {
        if(i == 0)
            printf("%s", number[sumString[i] - '0'].c_str());
        else
            printf(" %s", number[sumString[i] - '0'].c_str());
    }
}