PAT_A1089 Insert or Merge

发布时间 2023-10-23 14:14:30作者: 永无荒城

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Merge Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6

Sample Output 2:

Merge Sort
1 2 3 8 4 5 7 9 0 6
#include<bits/stdc++.h>
using namespace std;
const int N = 105;
int n, a[N], b[N], r[N], olda[N];

bool isSame(int c[]){
	for(int i = 0; i < n; i++)
		if(c[i]!=b[i]) return false;
	return true;
}

void merge(int lo, int mi, int hi, int a[]){ 
	int b[mi-lo], lb = mi - lo, lc = hi-mi;
	for(int i = 0; i < lb; i++) b[i]=a[lo+i];
	int i = 0, j = 0, k = 0;
	while(j < lb && k < lc)
		a[lo+(i++)] = b[j] < a[mi+k] ? b[j++] : a[mi+(k++)];
	while(j<lb) a[lo+(i++)] = b[j++];
}

// 递归版本的归并排序在这里不能用 
void mergeSort(int lo, int hi, int e[]){ 
	int en = 0;
	if(isSame(e)) en = 1;
	if(hi-1 <= lo) return;
	int mi = (lo+hi)/2;
	mergeSort(lo, mi, e);
	mergeSort(mi, hi, e);
	merge(lo, mi, hi, e);
	if(en) return;
}

void mergeSortIt(int lo, int hi, int e[]){
    int l = hi - lo, en=0;
    for (int step = 2; step/2 < l; step*=2) {
    	if(isSame(e)) en = 1;
        for (int i = 0; i < l; i+=step) {
            int mi = lo + i + step/2;
            if(mi < hi) merge(lo+i, mi, min(lo+i+step, hi), e);
        }
        if(en) return;
    }
}

bool insertSort(int lo, int hi, int a[]){
	int l = hi - lo, en = 0;
	for(int i = 0; i < l; i++){
		if(isSame(a)) en = 1;
		int p = upper_bound(a+lo, a+lo+i, a[i]) - a;
		int t = a[i], q = i;
		while(q > p){
			a[q] = a[q-1];
			q--;
		}
		a[p]=t;
		if(en)
			if(!isSame(a))  // 测试点2 
				return true;
	}
	return false;
}

int main(){
	cin>>n;
	for(int i = 0; i < n; i++){
		cin>>a[i];
		olda[i] = a[i];
	}
	for(int i = 0; i < n; i++) cin>>b[i];
	if(insertSort(0, n, a)){
		cout<<"Insertion Sort"<<endl;
		for(int i = 0; i < n; i++){
			if(i!=0) cout<<" ";
			cout<<a[i];
		}
	}else{
		mergeSortIt(0, n, olda);
		cout<<"Merge Sort"<<endl;
		for(int i = 0; i < n; i++){
			if(i!=0) cout<<" ";
			cout<<olda[i];
		}		
	}
	return 0;
}

总结
1、 #排序 #two_pointers 模拟插入排序和归并排序,并输出算法下一次排序结果。
2、测试点2:如果插入排序中间的结果和上一次的结果相同,输出直到不同的插入结果

10  
3 1 2 8 7 5 9 4 6 0  
1 2 3 5 7 8 9 4 6 0  

Insertion Sort  
1 2 3 4 5 7 8 9 6 0 //√
1 2 3 5 7 8 9 4 6 0 //×

3、递归版本归并排序整体上先对左区间排序,再对右区间排序,这里应该使用迭代版本的归并排序。