1137 Final Grading(测试点3段错误、答案错误)

发布时间 2023-09-12 12:23:56作者: Yohoc

题目:

For a student taking the online course "Data Structures" on China University MOOC (http://www.icourse163.org/), to be qualified for a certificate, he/she must first obtain no less than 200 points from the online programming assignments, and then receive a final grade no less than 60 out of 100. The final grade is calculated by G=(Gmidterm×40%+Gfinal×60%) if Gmidterm>Gfinal, or Gfinal will be taken as the final grade G. Here Gmidterm and Gfinal are the student's scores of the mid-term and the final exams, respectively.

The problem is that different exams have different grading sheets. Your job is to write a program to merge all the grading sheets into one.

Input Specification:

Each input file contains one test case. For each case, the first line gives three positive integers: P , the number of students having done the online programming assignments; M, the number of students on the mid-term list; and N, the number of students on the final exam list. All the numbers are no more than 10,000.

Then three blocks follow. The first block contains P online programming scores Gp's; the second one contains M mid-term scores Gmidterm's; and the last one contains N final exam scores Gfinal's. Each score occupies a line with the format: StudentID Score, where StudentID is a string of no more than 20 English letters and digits, and Score is a nonnegative integer (the maximum score of the online programming is 900, and that of the mid-term and final exams is 100).

Output Specification:

For each case, print the list of students who are qualified for certificates. Each student occupies a line with the format:

StudentID Gp Gmidterm Gfinal G

If some score does not exist, output "1" instead. The output must be sorted in descending order of their final grades (G must be rounded up to an integer). If there is a tie, output in ascending order of their StudentID's. It is guaranteed that the StudentID's are all distinct, and there is at least one qullified student.

Sample Input:

6 6 7
01234 880
a1903 199
ydjh2 200
wehu8 300
dx86w 220
missing 400
ydhfu77 99
wehu8 55
ydjh2 98
dx86w 88
a1903 86
01234 39
ydhfu77 88
a1903 66
01234 58
wehu8 84
ydjh2 82
missing 99
dx86w 81

Sample Output:

missing 400 -1 99 99
ydjh2 200 98 82 88
dx86w 220 88 81 84
wehu8 300 55 84 84

 

思路:

1、将学生的分数信息存在结构体数组中,然后对结构体数组进行排序

2、用map来实现从student ID 到 数组下标的映射 

 

测试点3段错误:结构体数组的大小不能只开到10010,可能P,M,N中包含的用户各不相同,应该开到30000。

测试点3答案错误:final grade 是最后计算出来的G,而不是final exam的成绩

 

代码:

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<map>
#include<math.h>
#include<algorithm>
using namespace std;
struct Student{
    string name;
    int gp, gm, gf, gg;
    Student(){
        gp = -1;
        gm = -1;
        gf = -1;
    }
}student[30005];
bool cmp(Student s1, Student s2){
    if(s1.gg != s2.gg){
        return s1.gg > s2.gg;
    }
    if(s1.name != s2.name){
        return s1.name < s2.name;
    }
}
map<string, int> mp;
int main(){
    int p, m, n, index = 1;
    scanf("%d%d%d", &p, &m, &n);
    for(int i = 0; i < p; i++){
        string s; int gp;
        cin>>s>>gp;
        mp[s] = index;
        student[index].gp = gp;
        student[index].name = s;
        index++;
    }
    for(int i = 0; i < m; i++){
        string s; int gm;
        cin>>s>>gm;
        if(mp[s] > 0){
             student[mp[s]].gm = gm;
        }else{
            mp[s] = index;
            student[index].gm = gm;
            student[index].name = s;
            index++;
        }
    }
    for(int i = 0; i < n; i++){
        string s; int gf;
        cin>>s>>gf;
        if(mp[s] > 0){
             student[mp[s]].gf = gf;
        }else{
            mp[s] = index;
            student[index].gf = gf;
            student[index].name = s;
            index++;
        }
    }
    for(int i = 1; i < index; i++){
        int gm = student[i].gm;
        int gf = student[i].gf;
        if(gm > gf){
            student[i].gg = round(gm * 0.4 + gf * 0.6);
        }else{
            student[i].gg = gf;
        }
    }
    sort(student + 1, student + index, cmp);
    for(int i = 1; i < index; i++){
        if(student[i].gp >= 200 && student[i].gg >= 60){
             cout<<student[i].name<<" "<<student[i].gp<<" "<<student[i].gm<<" "<<student[i].gf<<" "<<student[i].gg<<endl;
        }
    }
    return 0;
}