1154 Vertex Coloring

发布时间 2023-08-25 22:47:55作者: Yohoc

题目

proper vertex coloring is a labeling of the graph's vertices with colors such that no two vertices sharing the same edge have the same color. A coloring using at most k colors is called a (proper) k-coloring.

Now you are supposed to tell if a given coloring is a proper k-coloring.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 104), being the total numbers of vertices and edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of colorings you are supposed to check. Then K lines follow, each contains N colors which are represented by non-negative integers in the range of int. The i-th color is the color of the i-th vertex.

Output Specification:

For each coloring, print in a line k-coloring if it is a proper k-coloring for some positive k, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
4
0 1 0 1 4 1 0 1 3 0
0 1 0 1 4 1 0 1 0 0
8 1 0 1 4 1 0 5 3 0
1 2 3 4 5 6 7 8 8 9

Sample Output:

4-coloring
No
6-coloring
No

 

题目大意:给出一个图(先给出所有边,后给出每个点的颜色),问是否满足:所有的边的两个点的颜色不相同

 

思路:

1、使用结构体数组来存储边,然后遍历所有的边,若存在边上两个端点的颜色相同的情况就输出No

2、可以利用集合来计算不同颜色的个数

 

代码:

#include<stdio.h>
#include<iostream>
#include<set>
#include<string.h>
int n, m, k;
bool v[10005][10005] = {0};
int color[10005];
using namespace std;
struct Edge{
    int node1, node2;
}edge[10005];
int main(){
    scanf("%d%d", &n, &m);
    for(int i = 0; i < m; i++){
        int x, y;
        scanf("%d%d", &x, &y);
        edge[i].node1 = x;
        edge[i].node2 = y;
    }
    scanf("%d", &k);
    for(int i = 0; i < k; i++){
        set<int> se;
        memset(color, -1, sizeof(color));
        for(int j = 0; j < n; j++){
            scanf("%d", &color[j]);
            se.insert(color[j]);
        }
        bool flag = true;
        for(int j = 0; j < m; j++){
            if(color[edge[j].node1] == color[edge[j].node2]){
                flag = false;
                break;
            }
        }
        if(flag){
            printf("%d-coloring\n", se.size());
        }else{
            printf("No\n");
        }
    }
    return 0;
}