1142 Maximal Clique(附测试点1,3错误分析)

发布时间 2023-09-04 15:30:56作者: Yohoc

题目:

clique is a subset of vertices of an undirected graph such that every two distinct vertices in the clique are adjacent. A maximal clique is a clique that cannot be extended by including one more adjacent vertex. (Quoted from https://en.wikipedia.org/wiki/Clique_(graph_theory))

Now it is your job to judge if a given subset of vertices can form a maximal clique.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers Nv (≤ 200), the number of vertices in the graph, and Ne, the number of undirected edges. Then Ne lines follow, each gives a pair of vertices of an edge. The vertices are numbered from 1 to Nv.

After the graph, there is another positive integer M (≤ 100). Then M lines of query follow, each first gives a positive number K (≤ Nv), then followed by a sequence of K distinct vertices. All the numbers in a line are separated by a space.

Output Specification:

For each of the M queries, print in a line Yes if the given subset of vertices can form a maximal clique; or if it is a clique but not a maximal clique, print Not Maximal; or if it is not a clique at all, print Not a Clique.

Sample Input:

8 10
5 6
7 8
6 4
3 6
4 5
2 3
8 2
2 7
5 3
3 4
6
4 5 4 3 6
3 2 8 7
2 2 3
1 1
3 4 3 6
3 3 2 1

Sample Output:

Yes
Yes
Yes
Yes
Not Maximal
Not a Clique

 

思路:

1、先判断是否是clique,即判断是否任意两边都相连;之后判断是否是maximal,即遍历所有不在集合中的剩余的点,看是否存在一个点满足和集合中所有的结点相连,最后如果都满足,那就输出Yes表示是Maximal cliqu

2、测试点1,3错误需要注意循环中有输出语句时要及时退出循环,防止重复输出

 

 

代码:

#include<stdio.h>
#include<vector>
using namespace std;
int main(){
    int Nv, Ne;    
    int E[205][205] ={0};
    scanf("%d%d", &Nv, &Ne);
    for(int i = 0; i < Ne; i++){
        int x, y;
        scanf("%d%d", &x, &y);
        E[x][y] = E[y][x] = 1;
    }
    int m;
    scanf("%d", &m);
    for(int i = 0; i < m; i++){
        int k;
        scanf("%d", &k);
        int u[205]; bool U[205] = {0};
        for(int j = 0; j < k; j++){
            scanf("%d", &u[j]);
            U[u[j]] = 1;
        }
        bool flag= true;
        for(int j = 0; j < k; j++){
            for(int w = 0; w < k && w != j; w++){
                if(!E[u[j]][u[w]]){
                    flag = false;
                    break;
                }
            }
        }
        if(!flag){
            printf("Not a Clique\n");
            continue;
        }else{
            bool flag1 = true;
            for(int j = 1; j <= Nv; j++){
                if(U[j])continue;
                bool flag2 = true;
                for(int w = 0; w < k; w++){
                    if(!E[u[w]][j]){
                        flag2 = false;
                        break;
                    }
                }
                if(flag2){
                    printf("Not Maximal\n");
                    flag1 = false;
                    break;
                }
            }
            if(flag1){
                printf("Yes\n");
                continue;
            }  
        }
    }
    return 0;
}