PAT_A 1038 Recover the Smallest Number

发布时间 2023-10-19 10:26:56作者: 永无荒城

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (≤104) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287
#include<bits/stdc++.h>
using namespace std;
const int N = 10000+5;
int n;
string s[N], r;
bool mycmp(string a, string b){
	return a+b < b+a;
}
int main(){
	cin>>n;
	for(int i = 0; i < n; i++) cin>>s[i];	
	sort(s, s+n, mycmp);
	for(int i = 0; i < n; i++) r += s[i];	
	while(r.size()!=0 && r[0]=='0') r = r.substr(1);
	r.size()==0? cout<<0<<endl : cout<<r<<endl;
	return 0;
}

总结
1、 #贪心 对数字串s1、s2,如果s1+s2 < s2+s1(+代表拼接),那么把s1放在s2的前面。
2、二维char数组排序较麻烦,这里用string。
3、考虑前缀去0后r为空的情况,此时输出0。