1094 The Largest Generation

发布时间 2023-04-20 18:27:09作者: 回忆、少年

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers  () which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to ), and  () which is the number of family members who have children. Then  lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] ... ID[K]
 

where ID is a two-digit number representing a family member, K () is the number of his/her children, followed by a sequence of two-digit ID's of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:

23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18
 
 

Sample Output:

9 4
 
 
代码长度限制
16 KB
时间限制
200 ms
内存限制
64 MB

 

代码实现:

#include<iostream>
#include<queue>
#include<cstring>
#include<vector>
using namespace std;
const int N=105;
vector<int>v[N];
int level[N];
void bfs(int x){
    queue<pair<int,int> >q;
    q.push({1,x});
    while(q.size()){
        int dis=q.front().first;
        int s=q.front().second;
        q.pop();
        level[dis]++;
        for(int i=0;i<v[s].size();i++){
            q.push({dis+1,v[s][i]});
        }
    }
}
int main(){
    int n,m;
    cin>>n>>m;
    while(m--){
        string s;
        cin>>s;
        int k;
        cin>>k;
        while(k--){
            string s1;
            cin>>s1;
            v[stoi(s)].push_back(stoi(s1));
        }
    }
    bfs(1);
    int max1=0;
    for(int i=1;i<=n;i++)max1=max(max1,level[i]);
    for(int i=1;i<=n;i++){
        if(level[i]==max1){
            cout<<level[i]<<" "<<i<<endl;
            break;
        }
    }
    return 0;
}