1004 Counting Leaves

发布时间 2023-04-20 18:12:04作者: 回忆、少年

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing , the number of nodes in a tree, and  (), the number of non-leaf nodes. Then  lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]
 

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with  being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02
 

Sample Output:

0 1
代码长度限制
16 KB
时间限制
400 ms
内存限制
64 MB
 

代码实现:

#include<iostream>
#include<queue>
#include<vector>
using namespace std;
const int N=1e5+5;
vector<int>v[N];
int level[N];
int idx;
void bfs(int root){
    queue<pair<int,int> >q;
    q.push({root,1});
    while(q.size()){
        int s=q.front().first;
        int dis=q.front().second;
        idx=max(idx,dis);
        q.pop();
        if(v[s].size()==0){
            level[dis]++;
            continue;
        }
        for(int i=0;i<v[s].size();i++){
            q.push({v[s][i],dis+1});
        }
    }
}
int main(){
    int n,m;
    cin>>n>>m;
    while(m--){
        string s;
        int k;
        cin>>s>>k;
        while(k--){
            string s1;
            cin>>s1;
            int x=stoi(s);
            int y=stoi(s1);
            v[x].push_back(y);
        }
    }
    bfs(1);
    for(int i=1;i<=idx;i++){
        if(i==1)cout<<level[i];
        else cout<<" "<<level[i];
    }
    return 0;
}