Oil Deposits

发布时间 2023-11-10 20:25:40作者: W_K_KAI

这道油田的原题在这边Online Judge

可以自行翻译一下,下面是我的代码注释,不懂可以在下面留言

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 ≤ m ≤ 100 and 1 ≤ n ≤ 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either ‘*’, representing the absence of oil, or ‘@’, representing an oil pocket.

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output

 0 
 1 
 2 
 2
#include<bits/stdc++.h>
using namespace std;

const int N = 110;
int n, m;
int d[8][2] = { 1,0,0,1,-1,0,0,-1,1,1,1,-1,-1,1,-1,-1 }; // 方向数组,表示八个方向
char a[N][N]; // 存储地图的字符数组
int ans; // 记录油田数量

void dfs(int x, int y) { // 深度优先搜索函数
    a[x][y] = '*'; // 将当前位置标记为已访问
    for (int i = 0; i < 8; i++) { // 枚举八个方向
        int nx = x + d[i][0]; // 计算下一个位置的横坐标
        int ny = y + d[i][1]; // 计算下一个位置的纵坐标
        if (nx <= 0 || ny <= 0 || nx > n || ny > m || a[nx][ny] == '*') { // 判断下一个位置是否越界或已访问
            continue; // 如果越界或已访问,则继续枚举下一个方向
        }
        dfs(nx, ny); // 否则继续搜索下一个位置
    }
    return; // 返回
}

int main()
{
    while (cin >> n >> m && (n || m)) { // 多组数据
        ans = 0; // 每组数据初始化油田数量为0
        for (int i = 1; i <= n; i++)
            cin >> a[i]; // 读入地图
        for(int i=1;i<=n;i++)
            for (int j = 1; j <= m; j++) { // 枚举每个位置
                if (a[i][j] == '@'){ // 如果当前位置是油田
                    ans++; // 油田数量加1
                    dfs(i, j); // 开始搜索
                }
            }
        cout << ans << endl; // 输出油田数量
    }
    return 0;
}