PAT_A1104 Sum of Number Segments

发布时间 2023-10-27 09:30:36作者: 永无荒城

Given a sequence of positive numbers, a segment is defined to be a consecutive subsequence. For example, given the sequence { 0.1, 0.2, 0.3, 0.4 }, we have 10 segments: (0.1) (0.1, 0.2) (0.1, 0.2, 0.3) (0.1, 0.2, 0.3, 0.4) (0.2) (0.2, 0.3) (0.2, 0.3, 0.4) (0.3) (0.3, 0.4) and (0.4).

Now given a sequence, you are supposed to find the sum of all the numbers in all the segments. For the previous example, the sum of all the 10 segments is 0.1 + 0.3 + 0.6 + 1.0 + 0.2 + 0.5 + 0.9 + 0.3 + 0.7 + 0.4 = 5.0.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N, the size of the sequence which is no more than 105. The next line contains N positive numbers in the sequence, each no more than 1.0, separated by a space.

Output Specification:

For each test case, print in one line the sum of all the numbers in all the segments, accurate up to 2 decimal places.

Sample Input:

4
0.1 0.2 0.3 0.4

Sample Output:

5.00
#include<bits/stdc++.h>
using namespace std;
long double t, r=0;
int main(){
	int n; scanf("%d", &n);
	for(int i = 1; i <= n; i++){
		scanf("%Lf", &t);
		// r += i*(n+1-i)*t;
		r += t*i*(n+1-i);
	}
	printf("%.2Lf\n", r);
	return 0;
}

总结
1、 #数学问题/简单数学
2、测试点3报错,原因是起初写的r += i*(n+1-i)*t;,i是int类型,最大可达$10^5$ ,两个int相乘会溢出。改变一下相乘的顺序即可:r += t*i*(n+1-i);
3、测试点2报错,原因是double精度不够,这里改用long double类型。
链接:[[../../c++语法/long double|long double]]