1155 Heap Paths

发布时间 2023-08-24 21:12:59作者: Yohoc

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.

Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (1<N1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.

Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. 

Sample Input 1:

8
98 72 86 60 65 12 23 50

Sample Output 1:

98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap

Sample Input 2:

8
8 38 25 58 52 82 70 60

Sample Output 2:

8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap

Sample Input 3:

8
10 28 15 12 34 9 8 56

Sample Output 3:

10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap

 

思路:

1、已知二叉树的层序遍历,可以使用数组来存储二叉树

2、a[index * 2] 和 a[index * 2 + 1] 为 a[index] 的子节点

3、dfs深度优先遍历所有的路径,用vector来存储路径

 

 

代码:

#include<stdio.h>
#include<vector>
#include<iostream>
using namespace std;
int n;
int a[1005];
vector<int> v;
bool isMin = true, isMax = true;
void dfs(int index){
    if(index * 2 > n && index * 2 + 1 > n){ // a[index]为叶子结点
        if(index <= n){
            for(int i = 0; i < v.size(); i++){
                printf("%d%s", v[i], i != v.size() - 1 ? " " : "\n");
            }
        }
    }else{
        v.push_back(a[index * 2 + 1]);
        dfs(index * 2 + 1);
        v.pop_back();
        v.push_back(a[index * 2]);
        dfs(index * 2);
        v.pop_back();
    }
}
int main(){
    scanf("%d", &n);
    for(int i = 1; i <= n; i++){
        scanf("%d", &a[i]);
    }
    v.push_back(a[1]);
    dfs(1);
    for(int i = 2; i <= n; i++){
        if(a[i / 2] < a[i]) isMax = 0;
        if(a[i / 2] > a[i]) isMin = 0;
    }
    if(isMin){
        printf("Min Heap");
    }else{
        printf("%s", isMax == true ? "Max Heap" : "Not Heap");
    }
    return 0;
}